Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Spaces are once again showing up in Reports

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Everything Else
View previous topic :: View next topic  
Author Message
mustbecrap



Joined: 31 May 2009
Posts: 7

PostPosted: Thu Aug 15, 2013 4:53 pm    Post subject: Spaces are once again showing up in Reports Reply with quote

Some time ago I had an issue with spaces showing up at the front of any report saved to an excel spreadsheet.. I posted on the forum at that time and the problem suddenly solved itself without me doing anything (obviously it was an internal thing)..

However today the problem is back.. I cannot export any report as a spreadsheet without all the information in the reports, the headers and the contents of the report itself, all being saved with a space at the front..

I have changed Nothing in the report, or the website, this is as it has been for the past 5 years... But as I said the problem has now reappeared..

My database system is designed to import these excel sheets, but due to the spaces it cannot import them and even if I force it to import the spreadsheet I soon find the data is useless because of the spaces at the front of all the information...


Either there is another internal problem with this, or some other issue..
Does anyone know what is going on..

Last time I submitted a post for this issue I got a response of this: "This could be caused by either adding, removing, or editing a field on the form"

However the above response is not right simply because as I mentioned I have not touched these forms in years. I could understand if I had been changing things, but as I don't alter the forms or the webpages it has nothing to do with my action... All I do these days is I login to mycontactform, go to the data message export area, export the data into an excel sheet and then log back out... I have changed nothing and have no need to...


thanks
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Fri Aug 16, 2013 3:29 am    Post subject: Re: Spaces are once again showing up in Reports Reply with quote

mustbecrap wrote:
Some time ago I had an issue with spaces showing up at the front of any report saved to an excel spreadsheet.. I posted on the forum at that time and the problem suddenly solved itself without me doing anything (obviously it was an internal thing)..

However today the problem is back.. I cannot export any report as a spreadsheet without all the information in the reports, the headers and the contents of the report itself, all being saved with a space at the front..

I have changed Nothing in the report, or the website, this is as it has been for the past 5 years... But as I said the problem has now reappeared..

My database system is designed to import these excel sheets, but due to the spaces it cannot import them and even if I force it to import the spreadsheet I soon find the data is useless because of the spaces at the front of all the information...


Either there is another internal problem with this, or some other issue..
Does anyone know what is going on..

Last time I submitted a post for this issue I got a response of this: "This could be caused by either adding, removing, or editing a field on the form"

However the above response is not right simply because as I mentioned I have not touched these forms in years. I could understand if I had been changing things, but as I don't alter the forms or the webpages it has nothing to do with my action... All I do these days is I login to mycontactform, go to the data message export area, export the data into an excel sheet and then log back out... I have changed nothing and have no need to...


thanks


I will correct this in a future update; likely in the coming weeks.

Nick Ladd
myContactForm.com
Back to top
View user's profile
mustbecrap



Joined: 31 May 2009
Posts: 7

PostPosted: Sun Aug 18, 2013 12:03 am    Post subject: Reply with quote

Nick,

the problem is that it has to be something that has only changed in the last 4 or so days...

As I mentioned the problem did appear around 6 months ago but disappeared again (overnight).. And its only just come back.

So I don't understand why you need to change or update, as it has to be associated with something that has occurred recently...

did you do an update in the last week, were there server changes etc... Something has happened to create this.

I have tested the export of the csv and other exports and its all the same, and I have tested this on different forms that I never export data from, but its the same for those as well.. So its not associated with one thing (one form)..

my problem is that with this issue it renders using mycontact useless as the information exported is not as it should be.. So I am hoping that your can undo whatever changes were made this week so the information can be exported. Else I hope I dont have to wait long for an update to fix the update (or whatever changes were made) that occurred this week...

As it is I am now being forced to look for an alternate source as all my new data is useless to me.. When contactform works it works fine, which is why my premium account is paid up to 2016 as I had now intentions of moving.. But at the moment its costing me more money in time as i have to manually correct the problem for every individual record before I can import the information into my database.

thanks
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Sun Aug 18, 2013 9:26 am    Post subject: Reply Reply with quote

After some extensive testing on our end, I am unable to reproduce the error. Is there a specific form in your account experiencing this? I've logged in to your account and run some test exports and did not have any extra spaces on any of the questions or answers.

Nick Ladd
myContactForm.com
Back to top
View user's profile
mustbecrap



Joined: 31 May 2009
Posts: 7

PostPosted: Sun Aug 18, 2013 3:57 pm    Post subject: Reply with quote

hi Nick,

The only forms in the account that I am concerned with are the easycode registration forms.. I dont export anything else..

These forms are deleted daily once exported, as the information is instantly imported into a database.. So at present it is not showing any, but some days there could be 10 and some days there could be only one.

I did attempt another export this morning from one of the other forms and i still get the same problem.. I tested it on another pc and still the same..

As you mention you dont see this fault at all, so I am starting to wonder then if maybe its not related to you but could it be a browser issue. Due to security issues I only use firefox.. IE, Chrome and many of the others are not secure enough so I never use them..

What browser are you using, because if its a browser issue (even though its never been a problem until now), I will install that browser just to be used for this task..

Let me know what browser you are using and I will run some more tests


thanks
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Mon Aug 19, 2013 2:13 am    Post subject: Reply Reply with quote

I am using Firefox 23.0.1.

Are you exporting as a CSV or Excel file? I think part of the issue could be coming from whatever method you are using to translate the data we're providing into whatever database you are using.

Nick Ladd
myContactForm.com
Back to top
View user's profile
mustbecrap



Joined: 31 May 2009
Posts: 7

PostPosted: Mon Aug 19, 2013 6:03 pm    Post subject: Reply with quote

Hi Nick,

Exporting to CSV and XLS still has the same issue... I ran another range of tests also with different browsers, but still no joy...

However I just discovered something...

Due to various issues my main pc's are now windows 8, so all my testing has been on windows 8 pc's, which is like taking a step backwards into the bad old days of Windows Me, it sucks big time.

As a last resort I have a pc that only handles email, and its windows xp, so I did another test on that (half expecting it to fail), but it is exporting the xls without any spaces.. I did it a couple of times and it worked with box csv and xls.... Its been working fine for over 6 months so I no idea why its suddenly stopped on the other pc's, unless microsoft did an update with windows 8 and they stuffed it all up.

I will keep an eye on it for a few days, but if the email server continues to work for these exports then i will just have to shuffle the info from that machine over to the core pc.. I am hoping this is the problem as whilst using the xp box is not totally solving the issue, I am happy to use that than to have to go through all the drama I have had to go through every day for the last week.

thanks
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Tue Aug 20, 2013 2:48 am    Post subject: Reply Reply with quote

Thank you for the info. We have not yet tested the site with Windows 8, but will try to do so in the future.

Nick Ladd
myContactForm.com
Back to top
View user's profile
fixmyblindsinc



Joined: 30 May 2012
Posts: 2

PostPosted: Mon Apr 28, 2014 9:49 am    Post subject: Spaces appearing upon export Reply with quote

I'm having this same issue. Just started today. There is a space just before all but one of the field names and is preventing me from uploading the excel file into my access database. We haven't changed anything on our form, website, etc.

What gives?
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Everything Else All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group