Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bug in "submit" button.

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
cawimagery



Joined: 26 Aug 2011
Posts: 1

PostPosted: Sat Aug 27, 2011 5:24 am    Post subject: Bug in "submit" button. Reply with quote

The "Submit" button on the form doesn't work when using Google Chrome on Windows, works on MAC and every other internet client but just dissapears along with the "* required field" text from the bottom of the form when using Google Chrome on a windows machine.

If anyone knows how to fix this it would be fantastic, because a lot of people use chrome now and i dont want to alienate customers.
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Mon Aug 29, 2011 6:33 am    Post subject: Reply Reply with quote

This is not an issue with myContactForm.com's forms. From your description, it sounds like you are embedding the code on your site via an iframe (this is very common in iweb if that is what you are using). One of the issues with this is that not all web browsers will render the size of an iframe exactly the same. If the browser (Chrome) does not make the iframe tall enough, it will clip the bottom of the form, screening out the submit button. The button is there, but the iframe is preventing it from being seen. To solve this, either don't use an iframe, or add additional space after the bottom of the form to force the iframe to render larger and not clip out the bottom of the form.

Nick Ladd
myContactForm.com
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Sat Jan 21, 2012 8:54 am    Post subject: Re: Submit Button is there, but not working Reply with quote

70Proracer07 wrote:
Link to Page:
http://speedysnascarchallenge.ning.com/page/sprint-cup-picks

After logging into MyContactForm.com, and up-dating my form to reflect the new list of Picks for the next 8 NASCAR races, I copied the code, inserted it into the page, and tried to submit a TEST RUN, of the form, and even though the "Submit" button is there, it does NOTHING! No conformation, No transfering to the main page, no error messages.

Even though the page shows up, it didn't save the "Black" background that I chose for this form, it loaded in yellow, so I went back to try to reset the settings, and the same thing happened again. I ended up having to adjust my site settings, to accommodate what the form was dictating to me.

Also, the page used to have gold font for the questions, and in the dropdown boxes the font was black. Now all the fonts are gold or yellow, which didn't show up very well on a white field. Had to go to a dark orange, which I'm not happy with, so that you can read the font in the white field.

I


Good Day,

I followed the link which you have provided. I cannot look at the code because it is behind a password protected site. Please either email me a username/password I can use to login or make it publicly accessible. I cannot diagnose the issues without looking at the code.

That being said, I can make a few guesses without viewing the code:

Issue #1 - Submit button not working
This is typically caused when the form is posted within an already open form tag on your site or when the code we've provided is not listed on the site correctly. Look at the source code on your site and see line by line if it looks the same as what we have provided.

Issue #2 - Issue with background color
If you have chosen to use alternating background colors behind the form questions, then this will take precedence over the selected background color and essentially override it. You must select 'No' if you want to use an overall background color. This setting is found on the second page of Edit > Form Appearance.

Issue #3 - Issue with font colors
To control the font colors and background colors of fields, under Edit > Form Appearance, Select 'Yes' When asked if you would like form elements to have a custom look. This is found on the third page under Edit > Form Appearance. This will allow you to control the styling of the form elements.

Nick Ladd
myContactForm.com
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Sat Jan 21, 2012 11:43 am    Post subject: Reply Reply with quote

Thank you for sending me your login information.

Issues #2 and #3 will be resolved if you use the instructions followed above.

Issue #1 with the submit button not working is also as I had suspected. If you look at the source code for the form on your site you will see the following:

Code:

<form style="background-color: #000000; margin: 0px; width: 100%; border: #ffff00 5px solid; padding: 0px;" id="contactForm" method="post" name="contactForm" action="http://www.mycontactform.com/sendform/sendform.php">
<p></p>
</form>


This is not the code that we have provided. The problem is that the form tag does not contain the actual fields and questions for the form. All of this is posted below the end form tag. The submit button doesn't do anything when pressed because it is not contained within the form tag. You need to paste the code to your site and ensure that it is published as we have provided. In its current format it will not work.

Nick Ladd
myContactForm.com
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Bug Reports All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group