Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Form Submission Error - did not fill out all of the required

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms
View previous topic :: View next topic  
Author Message
puddlez



Joined: 18 Feb 2010
Posts: 9

PostPosted: Thu Jul 08, 2010 6:32 pm    Post subject: Form Submission Error - did not fill out all of the required Reply with quote

I have a form located here: http://www.justimaginewebdesigns.com/DPM_Rental_Application/application.html. It consistently throws the following area for the fields shown in the message:

* We're sorry but you did not fill out all of the required fields. Please push the back button on your browser and fill out all of the required fields.
o Zip
o Income Amount

I thought it might be due to various design changes made in Dreamweaver, but as a test I pulled the html from the Form Management area. The error message is still the same. I tried double checked required vs not required and if there are any question # dupes besides selectable questions and came up with nothing.

Never had any issues with this service before, but could really use some feedback now.

Thanks!! Smile
Julie
julie_carlson@comcast.net
Back to top
View user's profile
puddlez



Joined: 18 Feb 2010
Posts: 9

PostPosted: Fri Jul 09, 2010 8:07 am    Post subject: Update Reply with quote

I tried some additional troubleshooting and I think I found the issue BUT I have no clue how to fix it because something is happening when the form code is being generated...

I tried creating a whole new form, same questions and question types.

Form url: http://www.justimaginewebdesigns.com/DPM_Rental_Application/rental_application.html

Result: Same issue - it states that information is incomplete on submission when it is being filled out - required or not - just to test.

Checked out teh details via Dreamweaver. Here's the thing... If you are in the form management area where you can edit teh questions numerically, the numbers and questions are correct. BUT when you select "get HTML" and review what is generated... There are several questions using question numbers twice (NOT option questions like radio buttons. Somehow when the html is generated there is a disconnect between the html and what appears in the form management area.

I've never experienced this issue before. Does anyone from this company have any suggestions? I really really do not want to step through this again. I've lost so much time on this that I might as well have done it for nothing.

Thanks
Julie
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2720

PostPosted: Sat Jul 10, 2010 6:46 am    Post subject: Reply Reply with quote

Good Day,

It appears that there are errors within the database record for the form. This most likely occurred due to the large # of questions on the form. Please try the following:

1. Delete the following questions from the form:

Type/Breed
Where Kept
Vehicle Year
Make
Current Employer Name
Occupation
State
Zip
Occupation
Supervisor Name
Current Employer Name
Hours per Week
Emergency Contact Name
Cell Phone #
Work Phone #
Home Phone #
Work Phone #
Cell Phone #
Relation

Basically, if you look at the HTML, delete any question where the q[#] portion of the code is duplicated between questions.

2. Once you have done this, re-add the questions via the 'Edit' page.

3. If this does not solve the issue, create a new form with a minimal # of questions (say 20), and then add the additional questions via the 'Edit' panel once the form is complete.

Nick Ladd
myContactForm.com
Back to top
View user's profile
puddlez



Joined: 18 Feb 2010
Posts: 9

PostPosted: Sat Jul 10, 2010 11:22 am    Post subject: Thanks Reply with quote

I got it working. I was going insane trying to find an error on my end...
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group