Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Attach a file

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms
View previous topic :: View next topic  
Author Message
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2724

PostPosted: Mon Sep 10, 2012 6:43 am    Post subject: Reply with quote

Try a couple things:

1. Check the emails in a different email client such as Gmail's web client of Thunderbird. Both are free.

2. Make sure your page is setup to use UTF-8 character encoding. You can ensure that you are using UTF-8 by inserting the following line into the <head> of your web document:

Code:
<meta http-equiv="Content-type" content="text/html; charset=utf-8" />


Nick Ladd
myContactForm.com
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2724

PostPosted: Tue Sep 11, 2012 7:05 am    Post subject: Reply with quote

IMAW wrote:
thanks for responding

1) on Gmail online the attachment is visible but not after downloading with Mac Mail App

2) We use attachments the whole day long and never have an issue with reading them except for the uploaded to email one via myConact from now

3) I did add that string to the HTML myContactForm gave me, added it right to the very top on it but no change in behavior.


Unfortunately, this is an issue with how Mac Mail encodes the messages. Try installing Thurderbird on the computer. It works in this app.
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2724

PostPosted: Wed Sep 12, 2012 6:19 am    Post subject: Reply with quote

IMAW wrote:
Can you explain to me how/why this is the only way attachments are unreadable with Mac mail? I mean emailing the very same attachment works great. Only when receiving the attachment via myContactFrom will change them?


It has to to with a proprietary standard Mac Mail uses to encode the messages. I do not have access to a Mac, so it is tough for me to reverse engineer the problem. Unfortunately, however it affects a small number of Mac users. The attachments encode correctly in every other mail client we have tested.

Nick Ladd
myContactForm.com
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group