Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Form not delivering completed fields properly

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
Paullylive



Joined: 22 Jan 2007
Posts: 2

PostPosted: Wed Feb 15, 2012 4:10 am    Post subject: Form not delivering completed fields properly Reply with quote

I have a form on my website where live bands register their details with us: http://www.blacktiegroup.com.au/actregister.html

Although they are filling in all the required information (and I've tested this myself), the bio field and songlist fields are not always coming through properly or at all. This has only just started happening in the past couple of weeks. This always worked fine previously. Some of our bands prefer to copy and paste all of their data into these fields, would this have something to do with the problem??? Too much data???

I thought I'd create a new form to see if this would fix the problem but again the songlist field won't deliver the songlist I pasted into that field. Here is the new form link: http://www.livebandsaustralia.com.au/band_sign_up.html

Any feedback on this would be very much appreciated.
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Wed Feb 15, 2012 9:27 am    Post subject: Reply Reply with quote

Right now your web page is configured to using character set: iso-8859-1. You can see this in the head of your web page:

Code:
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />


If there is special characters being pasted from a document into your form, this will likely cause problems. Change the above line of code to show the following instead:

Code:
<meta http-equiv="Content-type" content="text/html; charset=utf-8" />


This uses the UTF-8 encoding which is better supported. It should solve the problem.

Nick Ladd
myContactForm.com
Back to top
View user's profile
Paullylive



Joined: 22 Jan 2007
Posts: 2

PostPosted: Mon Feb 20, 2012 4:33 pm    Post subject: Reply with quote

Thanks Nick, that worked perfectly Smile
Back to top
View user's profile
jmbcomms



Joined: 28 Oct 2010
Posts: 10

PostPosted: Sat May 19, 2012 10:04 am    Post subject: Cut-Off (Incomplete) Submissions Reply with quote

Still happening. When I export to Excel, several submissions are incomplete.

My page code (adform.html) can be sent but I don't want it in a public forum. Help!

Jeff
Back to top
View user's profile
racarlson



Joined: 23 Nov 2008
Posts: 1

PostPosted: Thu May 24, 2012 11:53 am    Post subject: Form data not exporting properly Reply with quote

I am having the same issue as some other folks, but none of the solutions posted work for them. I receive e-mail confirmations with the correct data, but no matter what type of file I use as the export type, the data is jumbled. This isn't a characheter set or related issue. Again, the form data entered is correctly received because I see the correct data in the e-mail. For example, a field for phone number will show 427-989-1020 in the confirmation e-mail field, but when I see the record online or try to export it, it shows 427-989-1. This issue just started within the last few weeks. I have had a form up for a month, and just went to export data yesterday and found this issue. This really hurts. What can I do? Why is this happening?
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Fri May 25, 2012 8:26 am    Post subject: Re: Form data not exporting properly Reply with quote

racarlson wrote:
I am having the same issue as some other folks, but none of the solutions posted work for them. I receive e-mail confirmations with the correct data, but no matter what type of file I use as the export type, the data is jumbled. This isn't a characheter set or related issue. Again, the form data entered is correctly received because I see the correct data in the e-mail. For example, a field for phone number will show 427-989-1020 in the confirmation e-mail field, but when I see the record online or try to export it, it shows 427-989-1. This issue just started within the last few weeks. I have had a form up for a month, and just went to export data yesterday and found this issue. This really hurts. What can I do? Why is this happening?


Try rebuilding the form.

Nick Ladd
myContactForm.com
Back to top
View user's profile
myscott



Joined: 09 Jun 2009
Posts: 3

PostPosted: Mon Jul 09, 2012 1:08 pm    Post subject: Data in message center doesn't match emails Reply with quote

I am having the same problem. The data comes through the email correctly, but in the message center and PDF the answers don't go with the right questions. I even completely rebuilt the form using the Form Wizard. Any suggestions to try?
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Tue Jul 10, 2012 6:26 am    Post subject: Reply Reply with quote

Please do the steps outlined above. Make sure your page is using the utf-8 character set and try deleting and recreating the wrong questions.

Nick Ladd
myContactForm.com
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Bug Reports All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group