Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Error after submit

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms
View previous topic :: View next topic  
Author Message
nbrdesign



Joined: 27 Jun 2009
Posts: 3

PostPosted: Sun Jul 31, 2011 1:19 pm    Post subject: Error after submit Reply with quote

The submit button on http://atlanticbodyworkcenter.com/contact.html was taking users to http://atlanticbodyworkcenter.com/thanks.html fo 2 years now. All of a sudden, customers are getting this error:

Quote:
If you are the owner of this form you need to make sure to paste the html for the form that we provided you with exactly as it is onto your website.


I went to form management and made sure that the redirect url was correct and tested to make sure the redirect page worked on the site and all was well. So what does this error message refer to?
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2734

PostPosted: Mon Aug 01, 2011 4:41 am    Post subject: Reply Reply with quote

The error message is correct. The HTML that is actually on your site is incorrect and not as we provided. Several important hidden fields that identify your form to our processing server are not located within the <form> tag. This is why you're getting the error message. If you look at the source code on your site versus the actual code we have provided, you will see this. Please get fresh form code, add it to your site replacing your existing code, and then verify it has been updated.

Nick Ladd
myContactForm.com
Back to top
View user's profile
nbrdesign



Joined: 27 Jun 2009
Posts: 3

PostPosted: Tue Aug 02, 2011 8:27 am    Post subject: Submit still not working properly Reply with quote

Thanks. I have just copied and pasted the HTMl that is generated each time I update my forms. I have been using your forms for 2 years now and they work fine but not now.

Check out my year old site http://techniture.net and you will see that the contact form behaves correctly without my changing anything or recopying any HTML from mycontactform. But none of my other sites are working now.

At Atlantic Body Work Center I am now able to go to http://atlanticbodyworkcenter.com/contact.html , submit a message and it rediects to http://atlanticbodyworkcenter.com/thanks.html in a new browser tab.

However my page http://atlanticbodyworkcenter.com/contact.html appears in an iframe on the actual site and when I click on the send button it brings up the error message again within the iframe. What can I do to redirect the redirect page to the same iframe? Many of my websites have iframes ad I have never had this problem until now. This site was working properly with the iframes and mycontactform until just recently.

Again, check out http://techniture.net and it operates fine using the iframe.
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2734

PostPosted: Wed Aug 03, 2011 4:54 am    Post subject: Re: Submit still not working properly Reply with quote

cosmicgirl wrote:
Thanks. I have just copied and pasted the HTMl that is generated each time I update my forms. I have been using your forms for 2 years now and they work fine but not now.

Check out my year old site http://techniture.net and you will see that the contact form behaves correctly without my changing anything or recopying any HTML from mycontactform. But none of my other sites are working now.

At Atlantic Body Work Center I am now able to go to http://atlanticbodyworkcenter.com/contact.html , submit a message and it rediects to http://atlanticbodyworkcenter.com/thanks.html in a new browser tab.

However my page http://atlanticbodyworkcenter.com/contact.html appears in an iframe on the actual site and when I click on the send button it brings up the error message again within the iframe. What can I do to redirect the redirect page to the same iframe? Many of my websites have iframes ad I have never had this problem until now. This site was working properly with the iframes and mycontactform until just recently.

Again, check out http://techniture.net and it operates fine using the iframe.


Good Day,

This doesn't have anything to do with your frames.

http://techniture.net/ works because the required hidden fields are located within the form tag as we provide. If you look at the live source code, you can see this:

Code:
<form name="contactForm" method="post" action="http://www.mycontactform.com/sendform/sendform.php">

        <div align="center">
          <input name="user" type="hidden" id="user" value="cosmicgirl" />
          <input name="formid" type="hidden" id="formid" value="289853" />
        </div>
        <div align="left"></div>


http://atlanticbodyworkcenter.com/contact.html
doesn't work because the required hidden fields are located outside the form tag. Additionally this form is not appearing within an iframe as you have suggested. If you look at the live source code, you can see this:

Code:
<!-- Begin myContactForm.com Form HTML -->
      Leave us some feedback about our website or let us know about your Atlantic Bodywork Center experience. To make appointments use our  appointment button above.</strong></span><strong><span class="black">
<input name="user" type="hidden" id="user" value="cosmicgirl" />
<input name="formid" type="hidden" id="formid" value="289002" />
      </span>
      </strong>
    <form name="contactForm" method="post" action="http://www.mycontactform.com/sendform/sendform.php">
      <table width="50%" style="border: 0px solid #000000; margin: 0; padding: 0; background-color: #f5e8c6;">


In both cases, the live code on the site doesn't match what we have provided you. It looks like the authoring tools you are using is trying to be 'intelligent' and is shifting around your code. This is what is breaking your form.

Nick Ladd
myContactForm.com
Back to top
View user's profile
nbrdesign



Joined: 27 Jun 2009
Posts: 3

PostPosted: Wed Aug 03, 2011 9:10 am    Post subject: Thank you, Nick Reply with quote

I guess I see the issue now. I am going two days with just a few hours sleep and I guess I was focusing in on the fact that since the code was just as I copied it on mycontactform, it was the same when it pasted into Dreamweaver.
I appreciate you getting back to me so quickly.
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group