Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bookmarks ? anchors cause error

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms
View previous topic :: View next topic  
Author Message
tomecole



Joined: 17 Jan 2010
Posts: 2

PostPosted: Sun Jan 17, 2010 6:39 pm    Post subject: Bookmarks ? anchors cause error Reply with quote

I keep getting this error: * This form is not being sent from the url where it is supposed to be located. If you are the owner of this form you need to ensure that the 'Form Location' is specified as mysite.com/formsubmit.html. To change this, login to the site, click 'edit' next to the form's name, and then click the 'Basic Information' link to change the form's location.
Even though I have added all of my URL's that contain my sign-up form, when the user navigates to a "bookmark"/anchor point I get the error.
For instance I may have http://www.mysite.com/index.html defined as a location, but when the user clicks on a link to a bookmark/anchor (let's call it "service") lower on the page, that bookmark gets added to the URL so now it looks like the entire url is http://www.mysite.com/index.html#service and the form will fail with the above error.
Do I have to add each and every possible combination of url and bookmark, or is there some way to use wild cards to cover all possibilities?
Thanks
Back to top
View user's profile
mcfdude7



Joined: 20 Feb 2009
Posts: 19

PostPosted: Mon Jan 18, 2010 7:28 am    Post subject: Reply with quote

I don't think the #anchor in the URL should be causing the location error. I've got a form that has a link that includes a page anchor and it works fine without adding a url variation including the anchor to the list of form locations.

Have you included www and non-www versions?
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2743

PostPosted: Mon Jan 18, 2010 10:42 am    Post subject: Reply Reply with quote

mcfdude7 wrote:
I don't think the #anchor in the URL should be causing the location error. I've got a form that has a link that includes a page anchor and it works fine without adding a url variation including the anchor to the list of form locations.

Have you included www and non-www versions?


This is a good suggestion. Also, please try adding the anchored URLs to the form configuration (Login > Edit > Basic Form Information > Form Location).

Nick Ladd
myContactForm.com
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group