Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

ERROR: says required fields were not filled in
Goto page 1, 2  Next
 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms
View previous topic :: View next topic  
Author Message
dacton



Joined: 20 May 2008
Posts: 1

PostPosted: Thu Jun 25, 2009 8:38 pm    Post subject: ERROR: says required fields were not filled in Reply with quote

The forms will not work with required fields. Even though all required fields are filled in, I will get back this -
* We're sorry but you did not fill out all of the required fields. Please push the back button on your browser and fill out all of the required fields.
o Name:
o Office Name:
o Mailing Address:
o City:
o State:
o Zip Code:
o Phone:
o Your Website Link
o How will your ad be completed?
o My Ad Size Is:
o My Representative is:

This is effecting my business, please advise.
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Fri Jun 26, 2009 8:25 am    Post subject: Reply Reply with quote

Your form is not working because the code on your site is not the same as the code we have provided.

For example, for your first question (Name:) we've provided the following code:

Code:
<input name="q[1]" type="text" value="" size="" maxlength="30" />


If you look at the actual code on your website, it shows:

Code:
<input id="q" maxLength="150" size="30" name="q" [1] />


Notice that the id and name portions of the code are different than what we have provided. This was most likely changed by your CMS system or HTML editor without your knowledge, but is creating the problem. Try pasting the code into a text based editor, and it should work. It is imperative however that the code matches the code we have provided.

Nick Ladd
myContactForm.com
Back to top
View user's profile
trippergb



Joined: 04 Mar 2011
Posts: 9

PostPosted: Tue Aug 23, 2011 6:05 am    Post subject: Error: fill in all required fields Reply with quote

Hey guys,


Just as the first form i've made a year ago, it takes days again to finish our second one. Since the subjects left and boxes to fill in right were not leveled, and the order of subjects appeared different than the ones i filled in, i adjusted the form's html. Now when i submit the form, a message shows of "We're sorry but you did not fill out all of the required fields". Even though i let out the required fields completely, the same error messages popped up about required fields that were not there anymore.
I found out through the help forum that this was caused by a different html (i use dreamweaver). So i had to go through the whole form again, and pasted the html given in the page, still the same error message... I compared both codes, the one given and the source code of our page, both the same it seems.
Our (hotel) business is suffering from this as all our ads are linked to a website where potential guests will become very frustrating when they can't submit their requests and can't find another way yet to make their reservation... Our form is on http://www.guesthouseyangshuo.com/en/Yangshuo-Village-Retreat-Reservations.html
Please assist.
Back to top
View user's profile
trippergb



Joined: 04 Mar 2011
Posts: 9

PostPosted: Tue Aug 23, 2011 4:56 pm    Post subject: Same html appears different (all with errors) on 2 websites Reply with quote

In addition to the post below, we want to use the same form on 2 websites but both forms experience submission issues. When copied and pasted the html - over and over again for days now - in to this website: http://www.yangshuo-village-retreat.com/EN/reservations all lines appear unleveled, the calendars don't pop up but instead take you to the top of the form and, there is an error message showing 'did not fill in the required fields'.
When copied the same html to our other website http://www.guesthouseyangshuo.com/en/Yangshuo-Village-Retreat-Reservations.html there the error message appears as well 'not filled in required fields' but there the lay-out is alright and calendars do pop-up.
I've tried everything these days as it's so important these forms work well but nothing helps, please help !
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Wed Aug 24, 2011 4:41 am    Post subject: Re: Error: fill in all required fields Reply with quote

trippergb wrote:
Hey guys,


Just as the first form i've made a year ago, it takes days again to finish our second one. Since the subjects left and boxes to fill in right were not leveled, and the order of subjects appeared different than the ones i filled in, i adjusted the form's html. Now when i submit the form, a message shows of "We're sorry but you did not fill out all of the required fields". Even though i let out the required fields completely, the same error messages popped up about required fields that were not there anymore.
I found out through the help forum that this was caused by a different html (i use dreamweaver). So i had to go through the whole form again, and pasted the html given in the page, still the same error message... I compared both codes, the one given and the source code of our page, both the same it seems.
Our (hotel) business is suffering from this as all our ads are linked to a website where potential guests will become very frustrating when they can't submit their requests and can't find another way yet to make their reservation... Our form is on http://www.guesthouseyangshuo.com/en/Yangshuo-Village-Retreat-Reservations.html
Please assist.


I submitted the form and was unable to duplicate the problem with the required fields. It appears to have gone through. As for the alignment issues, this being caused by your CSS style sheet overriding how the calender image should be displayed. You can see within the style sheet at the page below that there is an img parameter which is adding a 20 pixel margin to all images.

http://www.guesthouseyangshuo.com/stylesheets/main.css

Nick Ladd
myContactForm.com
Back to top
View user's profile
trippergb



Joined: 04 Mar 2011
Posts: 9

PostPosted: Wed Aug 24, 2011 6:24 am    Post subject: Still the same problems here... Reply with quote

Hi Nick, thanks for the fast reply.

I tried the form on both of or webpages again and can't get how you were able to submit the form while i can't on several computers with different operating systems/browsers... On the page http://www.yangshuo-village-retreat.com/EN/reservations# i can't even open the calendar, and it's there the lines are not aligned.
On both pages the form won't submit, with the following error:
We're sorry but you did not fill out all of the required fields. Please push the back button on your browser and fill out all of the required fields.
Last Name:
Check Out:
Always those 2, (with check-in as well on the page above because the calendar doesn't pop up), and i can't see any difference in the code with our very similar form that's working well on this page: http://www.guesthouseyangshuo.com/en/Trippers-Carpe-Diem-Reservations.html
Any idea what's the issue here?
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Thu Aug 25, 2011 6:18 am    Post subject: Re: Still the same problems here... Reply with quote

trippergb wrote:
Hi Nick, thanks for the fast reply.

I tried the form on both of or webpages again and can't get how you were able to submit the form while i can't on several computers with different operating systems/browsers... On the page http://www.yangshuo-village-retreat.com/EN/reservations# i can't even open the calendar, and it's there the lines are not aligned.
On both pages the form won't submit, with the following error:
We're sorry but you did not fill out all of the required fields. Please push the back button on your browser and fill out all of the required fields.
Last Name:
Check Out:
Always those 2, (with check-in as well on the page above because the calendar doesn't pop up), and i can't see any difference in the code with our very similar form that's working well on this page: http://www.guesthouseyangshuo.com/en/Trippers-Carpe-Diem-Reservations.html
Any idea what's the issue here?


The alignment issues are happening because of the way you are styling the web page using:

http://www.yangshuo-village-retreat.com/EN/wp-content/themes/bespoke/style.css

This is also what is causing the calendar to not appear. If you are having issues with the required fields, delete the specific question experiencing the issues from the admin panel, re-add them in the admin panel, and then update the code on your website.

Nick Ladd
myContactForm.com
Back to top
View user's profile
Ekthana



Joined: 13 Nov 2011
Posts: 8

PostPosted: Fri Jan 06, 2012 2:34 am    Post subject: HTML Code Copied Verbatim But Errors When Submitting Forms Reply with quote


I have copied the HTML code and pasted it without making any changes to it what so ever but we are receiving errors that required fields aren't filled out even though they are. Browser tested are Firefox versions 6-8.01 IE Versions 7-9
FORM:
http://registration.ekthana.com/registration.html
Back to top
View user's profile
Ekthana



Joined: 13 Nov 2011
Posts: 8

PostPosted: Fri Jan 06, 2012 3:21 am    Post subject: Reply with quote

Every time I removed the settings in the error I would get new errors saying that other required fields where missing so I actually had to remove all of the required settings (except email address and subject which wouldn't allow me to remove the required setting)to get the form to work. Of course we can not do business this way so please help asap.
By the way email support for paid subscriptions would seem a requisite.
Back to top
View user's profile
Ekthana



Joined: 13 Nov 2011
Posts: 8

PostPosted: Fri Jan 06, 2012 3:42 am    Post subject: Reply with quote

As long as we are correcting problems I would also like to address another issue;
The form is being submitted to multiple email addresses that were set up for testing then removed and now even though it is clearly specified to send to only one it is being sent to three..
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Fri Jan 06, 2012 8:43 am    Post subject: Reply Reply with quote

Ekthana wrote:
As long as we are correcting problems I would also like to address another issue;
The form is being submitted to multiple email addresses that were set up for testing then removed and now even though it is clearly specified to send to only one it is being sent to three..


Please make sure that you have changed the send to address settings under:

Edit > Send to Address

Also, please make sure that you are editing the correct for and that you do not have any external email forwarding outside of mycontactform.com.

Nick Ladd
myContactForm.com
Back to top
View user's profile
Ekthana



Joined: 13 Nov 2011
Posts: 8

PostPosted: Fri Jan 06, 2012 5:03 pm    Post subject: Re: HTML Code Copied Verbatim But Errors When Submitting For Reply with quote

Ekthana wrote:

I have copied the HTML code and pasted it without making any changes to it what so ever but we are receiving errors that required fields aren't filled out even though they are. Browser tested are Firefox versions 6-8.01 IE Versions 7-9
FORM:
http://registration.ekthana.com/registration.html


This is a very serious issue can someone please address it right away?

mycontac wrote:
Ekthana wrote:
As long as we are correcting problems I would also like to address another issue;
The form is being submitted to multiple email addresses that were set up for testing then removed and now even though it is clearly specified to send to only one it is being sent to three..


Please make sure that you have changed the send to address settings under:

Edit > Send to Address

Also, please make sure that you are editing the correct for and that you do not have any external email forwarding outside of mycontactform.com.

Nick Ladd
myContactForm.com

There is only one form, and one email addresses and the send to single address button is checked additionally there is no external forwarding.
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Fri Jan 06, 2012 10:06 pm    Post subject: Reply Reply with quote

I am unable to diagnose what is happening with your form. The form will only be sent to the address this is configured under the Send to Address setting. Either the wrong form is being edited, or there is something external happening elsewhere.

With the required fields, you need to delete and recreate all questions associated with this issue. You're likely best off simply rebuilding the form.

Nick Ladd
myContactForm.com
Back to top
View user's profile
Ekthana



Joined: 13 Nov 2011
Posts: 8

PostPosted: Sat Jan 07, 2012 5:04 am    Post subject: Re: Reply Reply with quote

mycontac wrote:
I am unable to diagnose what is happening with your form. The form will only be sent to the address this is configured under the Send to Address setting. Either the wrong form is being edited, or there is something external happening elsewhere.

With the required fields, you need to delete and recreate all questions associated with this issue. You're likely best off simply rebuilding the form.

Nick Ladd
myContactForm.com

That's it? What is the cause of the issue? And how is rebuilding the form going to resolve it? We paid someone to create this form and were assured that mycontactform.com was a reliable organization with a stable, reliable and quality product. Now you are saying that the form which has exactly 0 submissions is worthless and should be rebuilt with no hint of what caused the issue or that it won't resurface after rebuilding the form?
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Sun Jan 08, 2012 7:09 am    Post subject: Reply Reply with quote

There is a corruption in the original database record for your particular form. This had existed since the form was created, but only became a problem after our most recent update.

The original issue that causes the corruption has been fixed, but you'll need to recreate the form.

Nick Ladd
myContactForm.com[/url]
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group