Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Submit Not Working

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms
View previous topic :: View next topic  
Author Message
sdacp



Joined: 23 Aug 2010
Posts: 2

PostPosted: Sat Feb 01, 2014 4:22 pm    Post subject: Submit Not Working Reply with quote

The submit button on this page is not working: http://www.sandiego.acp-international.com/index.php/component/content/article/8-events/13-meeting-registration

I also notice that validaion on the email address is not being performed. I searched the forum, and have checked for orphaned </form> which seems to be the cause of many similar problems and I don't see one. The site is in Joomla. Also tested in Firefox and the email validation does work, but submit still does not. Thank you!
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2684

PostPosted: Mon Feb 03, 2014 2:53 am    Post subject: Reply Reply with quote

Good Day,

If you look at the live source code for the page, you will see the following on line 190:

Code:
<form name="contactForm" id="contactForm" method="post" style="width: 100%; border: 0px solid #000000; margin: 0; padding: 0; background-color: #FFFFFF;">


The myContactForm.com code is missing the 'action' and 'enctype' parameters in the form tag. This is provider for in the code we've provided, but for some reason is not making it to you page. This is the reason the form is not working.

Nick Ladd
myContactForm.com
Back to top
View user's profile
sdacp



Joined: 23 Aug 2010
Posts: 2

PostPosted: Mon Feb 03, 2014 7:44 am    Post subject: Problem solved! Reply with quote

That was the problem - the action button was being removed on the save of the article. I got around it by changing my user privledges to SuperUser - that allowed the correct code to be saved. Thank you for the quick response!
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group