Back to myContactForm.com - Easy email form creation and processing for your web site
myContactForm.com - Help Forum Forum Index myContactForm.com - Help Forum
Have a question that you need answered about myContactForm.com? Post it on this message board but first search this forum and read out FAQ to ensure it has not already been answered. This is not a board to post links to your site! SPAM will be deleted!
 
   Search MessagesSearch Messages
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Form not submitting or redirecting

 
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms
View previous topic :: View next topic  
Author Message
molander



Joined: 28 Apr 2010
Posts: 1

PostPosted: Tue May 18, 2010 12:57 pm    Post subject: Form not submitting or redirecting Reply with quote

Hello, I am a new Premium Member using the forms for the first time and seem to be having an issue that lots of people have. I have already read through the posts and tried many suggestions you have given, as well as read all the FAQs I could find.

My code for the form copies into a Joomla template and the form appears on the web page just fine. However, I have submitted many times over the last few days to test out the form, and I do not receive the submitted form. I have checked the email accounts that it's submitted to and everything seems to be working, otherwise. Also...my redirect page is not functioning...after submitting the form, it just resets. I wanted it to go "home".

Here is my location of my form:

http://www.industrialconsolidatedservices.com/get-a-quote.html

This is a very important form for us on our site...please let me know if you see anything I can do to fix this as soon as possible. Thank you!
Back to top
View user's profile
mycontac
Site Admin


Joined: 31 Dec 2003
Posts: 2735

PostPosted: Wed May 19, 2010 6:31 am    Post subject: Reply Reply with quote

Good Day,

The issue is that the form HTML on your web site is significantly different than the form code that we have provided. I am not familiar with Joomla, but it appears that the software you are using to embed the form HTML is altering it to the point that it will not function. While several items within the code are different, the specific one that is causing the form to not send is:

Code on your site:
Code:
<form name="contactForm" method="post">


Code for the form that we provided:
Code:
<form name="contactForm" method="post" action="http://www.mycontactform.com/sendform/sendform.php">


As you can see, the form on your website is missing the 'action' portion of the HTML. This portion is key as it tells the web browser where to submit the form data for processing. Without it, when the submit button is hit, it will simply refresh the web page.

Sincerely,

Nick Ladd
myContactForm.com
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    myContactForm.com - Help Forum Forum Index -> Errors When Submitting Forms All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB 2.0.11 © 2001, 2002 phpBB Group